الرئيسية

السبت، 28 يناير، 2017

طريقة عمل باقة بتحميل محدد وسرعة تتغير بعد إنتهاء رصيد التحميل في المايكروتك | مجاناً من ماكس أبجريد

بسم الله الرحمن الرحيم

تلبية لطلب بعض الأخوة في جروب الفيس بوك
عن انشاء باقة في المايكروتك بتحميل محدد وسرعة محددة وبعد أن ينتهي رصيد التحميل الخاص به
تتغير السرعة إلى سرعة أقل إلى ان تنتهي صلاحية اليوزر حسب صلاحية الباقة المحددة





الطريقة كالتالي :

نقوم بإنشاء بروفايل في اليوزر مانجر
بالصلاحية الذي نريد


ثم نقوم بتعديل السعر والصلاحية ومن ثم حفظ

ثم نذهب إلى التحديدات ونقوم بإنشاء تحديد جديد ونقوم بكتابة إسم الجروب كما بالصورة
لربط هذا البروفايل بالبروفايل في الهوتسبوت

ثم نعود مرة أخرى إلى البروفايلات ونقوم باضافة تحديد كما بالصورة


ثم بالهوتسبوت user profile نقوم بإنشاء بروفايل جديد ونقوم بتسميته بنفس الاسم في التحديد باليوزر مانجر group name

ثم من قائمة سكريبت نقوم بعمل السكريبت الخاص بتحويل السرعة
مع تغيير القيم


السكريبت في on-login
{
:local upld [:tonum [/tool user-man user get $user upload-used]];
:local downld [:tonum [/tool user-man user get $user download-used]];
:local tr ($upld + $downld);
if ($tr > 1073741824) do={
/queue simple add max-limit=128k/128k name=$user target=$address;
} else {
/queue simple add max-limit=256k/1024k name=$user target=$address;
}
}
:local out [/ip hotspot get 0 interface];
/queue simple remove [find target=$out];



في هذا السكريبت السرعة المحددة هي 1024 تنزيل و 256 رفع
  ( 1073741824) وبعد انتهاء التحميل المحدد وهو في هذا السكريبت : 1 جيجا
يكون تحديد السرعة 128 تنزيل ومثلها رفع
تستطيع تغيير القيم في السكريبت حسب رغبتك .

-----------------------
السكريبت في on-logout

/queue simple remove [find name=$user];


-------------------------------


الطريقة الأخرى ليوزرات الهوتسبوت فقط بدون استخدام اليوزر مانجر:

عن طريق انشاء بروفايلين في الهوتسبوت كالتالي :


الخطوة الأولى : لصق الرول التالي مع تغيير السرعه 1024 الى السرعة المطلوبة قبل انتهاء الرصيد 


ip hotspot user profile add name=ahmeda rate-limit=1024k/1024k/

الخطوة الثانية : لصق الرول التالي في ترمنال مع تغيير السرعة 128 الى السرعة المطلوبة بعد انتهاء الرصيد 


ip hotspot user profile add name=ahmedb rate-limit=128k/128k/




السكريبت في البروفايل الاول ahmeda في on-logout

 /queue simple remove [find name=$user];
 {
:local upld [:tonum [/ip hotspot user get $user bytes-in]];
:local downld [:tonum [/ip hotspot user get $user bytes-out]];
:local tr ($upld + $downld);
:local limit [:tonum [/ip hotspot user get $user limit-bytes-total]];
if ($tr >= $limit) do={
/ip hotspot user rest-counter $user;
/ip hotspot user set [find name=$user] profile=ahmedb;
}
}


ثم ننشأ يوزرات الهوتسبوت باختيار البروفايل الذي قمنا بإنشاءه .. ahmeda

مع تحديد التحميل في اليوزرات عند انشائها في 
limit bites total
بالتحميل المطلوب بالبايت

1 جيجا =  1073741824




---------------------------
الطريقة حصرية وخاصة بماكس أبجريد
اتمنى لكم الاستفادة .. ونرجوا ذكر المصدر عند النقل ...


للانضمام لجروبنا على الفيس بوك
https://www.facebook.com/groups/897307696948269



بقلم الكاتب :
مهندس / أحمد محمد العليمي
هندسة وبرمجة شبكات | اليمن - صنعاء | ت : 771204505 - 736024667

هناك 22 تعليقًا:

  1. والي معه التقسيم حسب الاكتيف

    ردحذف
  2. أزال المؤلف هذا التعليق.

    ردحذف
  3. يا استاذ احمد انا معي على حسب الاكتف اول مايدخل الكرت بابروفايل الجديد هذ يحدد زيما قلت بس لوما يشتغل السكربت حسب الاكتف يحددلها سرعة حقة مثل اليوزرات الباقية مافيش حل مثل /queue simple set [ find name=asd ] max-limit=64k/128k; للاسكربت الجديد هذا

    ردحذف
  4. معي نفس المشكلة الخاصة بالاخ ابراهيم
    -------------------------------
    يا استاذ احمد انا معي على حسب الاكتف اول مايدخل الكرت بابروفايل الجديد هذ يحدد زيما قلت بس لوما يشتغل السكربت حسب الاكتف يحددلها سرعة حقة مثل اليوزرات الباقية مافيش حل مثل /queue simple set [ find name=asd ] max-limit=64k/128k; للاسكربت الجديد هذا

    ردحذف
  5. الذي معه تقسيم حسب الاكتيف ان شاء الله بيتم تحديث الموضوع ونشرح الطريقة

    ردحذف
    الردود
    1. يا استاذ احمد اين الحل لاصحاب التقسيم حسب الاكتف

      حذف
  6. لازم اليوزر يسجل خروج ويرجع يسجل دخول علشان نفحصه بالسكربت,, إذا اشتي مباشر وهو مازال اكتف وصل للحد اشتي اطيره من الكيواللي هو فيه وادخله بالكيو الجديد من غير مايسجل خروج فهل ممكن

    ردحذف
  7. هاذي قيمة بحجم 1 قيقا لاكن كيف اعرف القيمة من قيمة 500 ميقا وقيمة2 قيقا وقيمة 4قيقا وقيمة 6 قيقا وقيمة 8 قيقا و12 قيقا ما العملية الحسابية التي اقدر اعرف قيمة كل باقة مثل ما اريد

    ردحذف
  8. منتظرين منك حل الموضوع فيما اذا التقسيم حسب الاكتف

    ردحذف
  9. منتظرين منك حل يابش مهندس لمشكلة المجله ..كيف نسمح لاي بي المجله مع الحمايه من النت كت كت ترا الحمايه اوقفت المجله والقناه ..علما ان ان القناه والمجله هي الحل الوحيد لمشكلة الاستخدام العادل

    ردحذف
  10. السلام عليكم استاذ احمد بس هى مش شغاله عندى لما بخلص المتحدد بيطردنى من الاكتف وشكرا

    ردحذف
  11. الطريقه شغاله تمام و مافيش اى مشكله فيها محتاجين بقى البرودباند مع اليوزر مانجر و تبقى كده 100/100 اوى اوى اوى

    ردحذف
  12. استاذ أحمد الاسكربت بتاع الهوتسبوت مش شغال معى مش بيحول العميل على ahmedb وانا عامل الخطوط مظبوطة ممكن اعرف السبب وشكرا

    ردحذف
  13. https://youtu.be/HreXU-hrIwc

    شرح الطريقة هنا مع السكريبت الصحيح

    ردحذف
  14. لو سمحت كنت عوز اعرف لو انا عامل يوزر فى الهوت سبوت محددلة وقت ساعة ازى اخلى الميكروتك يحسب لليوزر من اول ما يسجل دخول اول مرة مثلن سجل الساعة 11يروح يفصل علية الساعة 12 بمعنى يحسب للعميل الوقت من اول مرة يسجل فيها دخول لان المعروف فى الهوت سبوت لم محدد لليوزر ساعة ميفصلش الخدمة الى بعد ما يشتغل العميل ساعة كاملة وشكرا

    ردحذف
  15. جديد 2017
    افتتاح موقع ميكروتك ون و الذي يقدم مواضيع حصرية في مجال الميكروتك
    www.mikrotik1.tk

    ردحذف
  16. نقدم لكم شركة الصفا والمروه لخدمات للخدمات المنزلية بمحافظة الخبر والتي تقدم افضل خدمات التنظيف ومكافحة الحشرات وكشف تسربات المياه وتسليك المجاري ونقل العفش والاثاث فمن خلال شركة كشف تسربات المياه بالخبر تستطيعون الحصول علي افضل خدمات كشف تسربات المياه الكترونيا وبدون تكسير مع الاصلاح والضمان باسخدام افضل الاجهزة الالكترونية الحديثة المستخدمة في كشف اماكن تسربات المياه والغازات عن بعد والتي توفر لعملائنا عناء البحث الشديد عن اماكن التسربات وتجنب التكسير الذي يكلف نفقات عالية وخسائر كبيرة وهذه الخدمة متوفرة فقط بهذه الامكانية وهذه الخبرة مع شركة كشف تسربات المياه بالخبر كما تقدم شركة الصفا والمروه للخدمات المنزلية بالخبر افضل خدمات التنظيف بالاستعانة بامهر وافضل العمالة ذات الخبرة الكبيرة في مجالات التنظيف وذات القدرة العالية علي خدمة عملائها باستخدام كافة الطرق والاساليب الحديثة وتسطيع شركة تنظيف بالخبر تقديم الخدمات الاتية وهي تنظيف المنازل وتنظيف الشقق وتنظيف الفلل وتنظيف السجاد وتنظيف الموكيت وتنظيف الفلل وتنظيف المنازل وتنظيف البيوت وتنظيف القصور وجميع خدمات التنظيف الاخري بالاستعانة بافضل وامهر العمالة المتميزة والتي تضمن لعملاء شركة الصفا والمروه الخودة والدقة والتميز وتستطيعون الحصول علي خدمات التنظيف من خلال شركة تنظيف منازل بالخبر
    ايضا توفر شركة الصفا والمروه خدمات مكافحة الحشرات ومكافحة النمل الابيض بالخبر والدمام من خلال شركة مكافحة النمل الابيض بالخبر والتي من خلالها تضمن لعملائها القضاء التام وابادة الحشرات بجمبع انواعها باستخدام اقوي المبيدات الامنة والفعالة وذات القدرة العالية علي الفتك بجميع الحشرات الطائرة والزاحفة بجميع انواعها كما تقدم شركة مكافحة التنل الابيض بالخبر خدماتها من خلال الشمان المميز والذي يضمن لعملاء شركة الصفا والمروه الحصول علي خدمة مثالية ومميزة بضمان من الشركة لمدة 6 اشهر من تاريخ تنفيز العملية وتتوفر تلك الخدمات مع شركة مكافحة النمل الابيض بالخبر - شركة مكافحة حشرات بالخبر
    ايضا توفر شركة تسليك مجاري بالخبر والدمام والتي من خلالها تستطيع جميع اهالي محافظة الخبر والدمام التخلص من مشكلة انسداد مجاري المياه وبالوعات الصرف للمطابخ والحمامات وكذلك شبكات الصرف الرئيسية , فهي من المشاكل الصحبة والتي يحتاجها اهالي المملكة العربية السعودية ولا يمكن التغلب عليها الا من خلال شركة تسليك مجاري متخصصة ولديها خبرة وكفاءة عالية وقد نجحت شركة تسليك مجاري بالخبر في الحصول علي ثقة عملائها من خلال الخدمات المتيزة والدقيقة التي قدمتها لعملائها واصبح يعتمد عليها الان الكثير من اهالي محافظة الخبر في حل مشاكل تسربات المياه وتسليك مجاري المياه وشفط البيارات فمع شركة تسليك مجاري بالخبر انتم دائما في امان ومن هنا نستطيع القول بان شركة الصفا والمروه هي افضل شركة تنظيف بالخبر وافضل شركة كشف تسربات بالخبر وافضل شركة مكافحة حشرات بالخبر وافضل شركة تسليك مجاري بالخبر واصبحت بدورها الفعال في خدمة عملائها وحرصها الشديد علي تقديم خدمات مثالية لمكافحة الحشرات رائدة شركة التنظيف ومكافحة الحشرات بالخبر
    المصدر
    https://safa-marwa.com
    شركة الصفا والمروه

    ردحذف
  17. سلام عليكم اخ احمد
    عندي مشكلة صغيرة ارجو الافادة
    عندما احاول انشاء بروفايل في اليوزر مانجر تظهر الرسالة التالية
    profile with such name-for-user already exists
    مع انو بروفايل جديد واسم جديد يعني مو مكرر

    ردحذف